Visual Studio Error – Entity Data Model Wizard Not Responding

There is is a kind of bug in visual studio that is very annoying.

While working with visual studio, When you try to add an entity data model through wizard, after the second wizard step (when it says choose your data connection), clicking Next makes the wizard window not responding and after a while the wizard window disappears without any warning or error. This is very frustrating as no support is provided by Microsoft regarding this error and no clear reason behind this bug is known.

I am also not aware of the exact reason behind the error, but I found a simple and easy way the worked for me to get rid of this. I am not sure if this will work for you, but give it a try before you are thinking of re-installing Visual Studio. Below I attached the screenshots of the wizard where actually the error problem is.

                       entity framework model wizard not respondingentity framework model wizard not responding
Let’s start with the solution that worked for me.

1. Open the Server Explorer window.

2. Expand the Data Connections to see all the connections that are already created.

 visual studio-entity framework error

3. Delete all the unnecessary Data Connections .I recommend you to delete all of them. I found this can be a bug with some data connections that might be left in some unresponsive states.

4. In order to delete a data connection, right click on it and select Delete. After deleting the data connections, the problem gone straightway for me.

                        entity framework error
This problem can occur both in visual studio 2010 and visual studio 2012.Try this and let me know if this works for you.


  1. Zc Gyu

    Thanks a lots. You save the world 😀

  2. Zc Gyu

    Thanks a lots. You save the world 😀

Leave a reply